Forum rules
RUNALYZE started as one-man-project with only one user and has grown to an app with around 15.000 users of our official online version. Server requirements and complexity of the app and its configuration grow with the feature list. Please understand that our main focus is on implementing new features and serving a performant online version. Therefore, support for local installations is limited and we cannot guarantee any support.

Please always provide log files (and screenshots, activity files if it makes sense) and all other needed information:

We spend our leisure time to make RUNALYZE as good as possible and we still have tons of great ideas, but time is scarce and after a hard training we first need some fruits or a smoothie. You can support the development of RUNALYZE with every financial contribution — We highly appreciate every grant.
Posts: 1
Joined: Wed 19. Jul 2017, 12:15

help req for queueing system : token_get_all error

Wed 19. Jul 2017, 12:29

hi all,

I could use some help in getting the queueing system to work.

The latest runalyze version v=4.1.2 is installed on my synology nas (dsm6.1, Apache/2.2.31 (Unix) mod_fastcgi/mod_fastcgi-SNAP-0910052141, php 7.0.16 (also tried 5.6.30), mysqlnd 5.0.12-dev - 20150407)
Followed the instructions given at ... ments.html, installed python3, rsvg-convert, added a cronjob as described.

Now if I run eg. web/my/tools/backup to start a backup job, the job appears in 1.job
When the queue is processed (php /volume1/web/runalyze/bin/console runalyze:queue:consume --env=prod --no-debug --max-runtime 120 --stop-when-empty) the name of the job changes to 1.job.proceed.
There are no errors in apache's error log, nothing is logged in var/logs, the backup job never completes.

Also, when trying the poster-generator a job is created in the queue dir var/queue/poster-generator , gets renamed to 1.job.proceed, no errors in var/logs or apache-error-log

Another example: Fatal error upon trying to clear the cache by issueing

Code: Select all

php /volume1/web/runalyze/bin/console cache:clear --env=prod
// Clearing the cache for the prod environment with debug
// false

PHP Fatal error: Call to undefined function Zend\Code\Reflection\token_get_all() in /volume1/web/runalyze/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 230

Fatal error: Call to undefined function Zend\Code\Reflection\token_get_all() in /volume1/web/runalyze/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 230

Attempted to call function "token_get_all" from namespace "Zend\Code\Reflec

cache:clear [--no-warmup] [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command>
I checked my phpinfo() for the tokenizer extension: is enabled

Not sure how to tackle this configuration, any help/direction is much appreciated, tia Mark
0 x

User avatar
Posts: 1463
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: help req for queueing system : token_get_all error

Thu 5. Oct 2017, 13:50

Synology Forum:
Other google search for that error returns:
Adjust the php.ini or try to call
php56 /volume1/web/runalyze/bin/console runalyze:queue:consume --env=prod --no-debug --max-runtime 120 --stop-when-empty
0 x
###Donate to RUNALYZE###
Höhenmeter (Korrektur & Berechnung) - Nutzerhilfe/User help -

Run Happy!,
P.S. Ich antworte gerne kurz und knackig ;)

Return to “Runalyze v4.1.x”

Who is online

Users browsing this forum: No registered users and 1 guest