Page 1 of 1

Problem beim Update von 3.2.0 -> 4.0.0

Posted: Tue 3. Oct 2017, 21:17
by roweinm
Hallo zusammen,
beim Versuch das Upgrade von V3.2.0 auf 4.0.0 auf meiner Synology Diskstation (DSM6.1) via CLI durchzuführen, erscheinen auf der Konsole folgende Fehlermeldungen:
PHP Fatal error: Call to undefined function Zend\Code\Reflection\token_get_all() in volume1/web/runalyze/vendor/zendframework/zeion/MethodReflection.php on line 230

Fatal error: Call to undefined function Zend\Code\Reflection\token_get_all() in /volume1/web/runalyze/vendor/zendframework/zend-coethodReflection.php on line 230
Was läuft hier schief ?
Danke im Voraus !

Gruß
Roland

Re: Problem beim Update von 3.2.0 -> 4.0.0

Posted: Wed 4. Oct 2017, 09:26
by mipapo
Fehlermeldung googeln:
https://www.drupal.org/node/2801947
Die tokenizer extension ist bei dir nicht enabled. Was sie standardmäßig ab PHP Version 5.5.x sein sollte.
Synology Forum: https://forum.synology.com/enu/viewtopic.php?t=115878

Re: Problem beim Update von 3.2.0 -> 4.0.0

Posted: Wed 4. Oct 2017, 20:45
by roweinm
Hallo Michael,
danke für den Hinweis !
Mit dem Aufruf von php56 anstelle php hat es geklappt. Bei meinem DSM 6 sind mehrere php Releases (warum auch immer) installiert.

Gruß
Roland