Forum rules
Please always provide the activity file and other needed information.
svf
Neuling
Posts: 3
Joined: Sat 20. Nov 2021, 15:44

Indoor Cycling Rides not Syncing (Garmin Connect)

Hi,

I have a problem regarding my indoor rides not showing up in runalyze.

I have added the sport indoor cycling in runalyze and the indoor rides have sport type "indoor cycling" in Garmin Connect but apparently the don't get synced. Everything else (like outdoor rides and runs) get synced correctly.

Does anyone has a tip how to figure out what's wrong?

Thanks!
User avatar
mipapo
Administrator
Posts: 1384
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel

Re: Indoor Cycling Rides not Syncing (Garmin Connect)

Are the indoor cyclings from Zwift or a third party vendor? Garmin doesn't send those to third parties like Runalyze. You need to sync them manually.
###Become a Runalyze supporter###
- Nutzerhilfe/User help -

Run Happy!,
Michael
P.S. Ich antworte gerne kurz und knackig ;)
Image
svf
Neuling
Posts: 3
Joined: Sat 20. Nov 2021, 15:44

Re: Indoor Cycling Rides not Syncing (Garmin Connect)

Yup they are from Trainerroad. That explains it.

I also do sync them to Strava. Does the route TR->Strava->runalyze should work in theory?
User avatar
mipapo
Administrator
Posts: 1384
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel

Re: Indoor Cycling Rides not Syncing (Garmin Connect)

svf wrote: Sun 21. Nov 2021, 16:48 Yup they are from Trainerroad. That explains it.

I also do sync them to Strava. Does the route TR->Strava->runalyze should work in theory?
Yes that works (and the only reason why we implemented the strava sync). The default setting we have for the Strava sync is that activities we are able to sync via direct connections are skipped. So it's save to connect Strava
###Become a Runalyze supporter###
- Nutzerhilfe/User help -

Run Happy!,
Michael
P.S. Ich antworte gerne kurz und knackig ;)
Image
svf
Neuling
Posts: 3
Joined: Sat 20. Nov 2021, 15:44

Re: Indoor Cycling Rides not Syncing (Garmin Connect)

Great! I'll give it a try. Thanks for the feedback and all the great work!

Return to “Importer / File problems”