Forum rules
Please always provide all needed information to identify your problems. Screenshots and detailed descriptions makes it easier for us to help https://help.runalyze.com/latest/support.html

We spend our leisure time to make RUNALYZE as good as possible and we still have tons of great ideas, but time is scarce and after a hard training we first need some fruits or a smoothie. You can support the development of RUNALYZE with every financial contribution — We highly appreciate every grant.
https://blog.runalyze.com/donate/
mpruchni
Neuling
Posts: 5
Joined: Sun 15. Apr 2018, 15:41

Uncorrect laps times when using Polar

Wed 5. Sep 2018, 10:06

Hello,
I'm afraid, Runalyze has problem with algorithm of importing Polar trainings, because differences between reality and Runalyze presentation are significant.
For example yesterday I lapped as on the picture (and I remember these times from my training):
Image
I see It doesnt show image (maybe only on preview), so link:https://imgur.com/a/gjXQXC7

But on runalyze I got:

www.imgur.com/a/ncaqaNn


I think its not just Polar data problem, because endomondo gives correct numbers:
www.imgur.com/a/Xu4mLgh
0 x

User avatar
laufhannes
Core developer
Posts: 714
Joined: Mon 29. Jul 2013, 20:59

Re: Uncorrect laps times when using Polar

Wed 5. Sep 2018, 10:15

Feel free to attach the original file from Polar - otherwise it's impossible for us to analyse the problem ;)
0 x
User help -- short questions via Twitter, Facebook

mpruchni
Neuling
Posts: 5
Joined: Sun 15. Apr 2018, 15:41

Re: Uncorrect laps times when using Polar

Wed 5. Sep 2018, 13:18

Here is the .tcx
Attachments
M_Urp_2018-09-04_19-06-58.tcx
(1.6 MiB) Downloaded 4 times
0 x

User avatar
laufhannes
Core developer
Posts: 714
Joined: Mon 29. Jul 2013, 20:59

Re: Uncorrect laps times when using Polar

Wed 5. Sep 2018, 14:09

Thanks for the file.

Explaining what happens here is not trivial. The laps themselves are correctly imported. If you take a look at what is shown in the activity view itself, you'll see the correct times.
Polar-import-laps.png
Polar-import-laps.png (20.89 KiB) Viewed 115 times
The 'wrong' times are only shown when opening the 'More details about your laps'. The problem is that Polar is inconsistent with its handling of times and that tcx is kind of a 'bad' file format. Importing the file gives a total duration of 1:15:15 (and an elapsed time of 1:17:32), but adding all lap times gives a total duration of 1:16:25. The tcx format is not able to mark pauses correctly, so it's possible that 1:16:25 is the official time your Polar device showed but it's impossible for us to get this exact value.

When importing the laps, their duration and distance are explicitly written in the tcx file. But for importing the continuous data, there's a long stream of numbers for e.g. heart rate and so on for a total duration of 1:16:25. Trying to show statistics for these values based on your laps is not possible by looking as the lap times, as somewhere 0:01:10 will be missing. That's why the 'More details about your laps' uses the lap's distances to split e.g. heart rate data into single laps. That's possible as the lap's distances sum up to 13.69 km and the file itself gives a total distance of 13.70 km (and such a small difference of 0.01 km is ignored).

So, in short: There's nothing we can do about this issue.
0 x
User help -- short questions via Twitter, Facebook

mpruchni
Neuling
Posts: 5
Joined: Sun 15. Apr 2018, 15:41

Re: Uncorrect laps times when using Polar

Wed 5. Sep 2018, 20:42

Thank You very much for quick answer.
There were pauses indeed.
0 x

Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest