Forumsregeln
RUNALYZE started as one-man-project with only one user and has grown to an app with around 13.000 users of our official online version. Server requirements and complexity of the app and its configuration grow with the feature list. Please understand that our main focus is on implementing new features and serving a performant online version. Therefore, support for local installations is limited and we cannot guarantee any support.

Please always provide log files (and screenshots, activity files if it makes sense) and all other needed information: https://docs.runalyze.com/en/latest/support.html

We spend our leisure time to make RUNALYZE as good as possible and we still have tons of great ideas, but time is scarce and after a hard training we first need some fruits or a smoothie. You can support the development of RUNALYZE with every financial contribution — We highly appreciate every grant.
https://blog.runalyze.com/donate/
pete13
Neuling
Beiträge: 19
Registriert: Fr 16. Sep 2016, 14:40

Re: Probleme bei Installation - fehlen von /install

Mi 8. Mär 2017, 16:06

Hi,
also ich würde mir mal die Logs von deinem Webserver anschauen. Bei einem 404 sollte da schon was hilfreiches drin stehen. Alternativ auch mal einen Blick in den Order var/logs/prod.log und var/logs/symfony.log im runalyze Verzeichnis werfen. Alternativ auch hier posten, irgendjemand sieht sich das schon an und gibt einen Tipp ab.
Was mir bei deiner Ordnerstruktur auffällt ist, dass die Dateien alle "root" gehören. Je nachdem unter welchen Benutzer dein Webserver läuft kann das zu Problemen führen.

Benutzeravatar
laufhannes
Core developer
Beiträge: 543
Registriert: Mo 29. Jul 2013, 20:59

Re: Probleme bei Installation - fehlen von /install

Mi 8. Mär 2017, 16:27

rnr hat geschrieben:
Mi 8. Mär 2017, 16:03
"Sorry, page not found" .I'm not a programer and not very familiar with symfony framework but think that problem is with some URL routing configuration settings.

Yep. Every 'Sorry, page not found' indicates a misconfiguration of the webserver. We suggest to mount a (sub)domain directly to the web-directory. In that case, nobody can (easily) access configuration files and Symfony does not have problems with url detection. In addition, we assume that everyone who wants to install a local version of RUNALYZE knows about 'url rewriting' and how to achieve that with his server.

For people using a local installation that can be reached via something like http://localhost/runalyze/... only, there should be no problem with accessing the installation via http://localhost/runalyze/web/app.php/ (just append e.g. 'install' for the installation). If this still fails, have a look at the 'RewriteBase' in the .htaccess file (at least for Apache servers like XAMPP).

As pete13 mentions, in case of any problems, there's in general a log entry in the server logs or in symfony logs var/logs/* (as long as the http request reaches symfony/runalyze) that gives a hint for the exact problem.

daniel1980
Neuling
Beiträge: 7
Registriert: Mo 6. Mär 2017, 10:20

Re: Probleme bei Installation - fehlen von /install

Mi 8. Mär 2017, 22:11

Hey everyone, maybe we could switch to english to adress more interested or maybe frustrated people.
I still do not get any further than log in screen. After that the browser adress line states "127.0.0.1/runalyze/web/dashboard" and the window displayed in the browser says "Sorry, page not found". Seem to be some internal mismatch... Here is my error_log from within runalyze:

[Wed Mar 08 21:58:59.003187 2017] [ssl:warn] [pid 1223] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Mar 08 21:58:59.003591 2017] [ssl:warn] [pid 1223] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Mar 08 21:58:59.003837 2017] [suexec:notice] [pid 1223] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Wed Mar 08 21:58:59.149825 2017] [auth_digest:notice] [pid 1224] AH01757: generating secret for digest authentication ...
[Wed Mar 08 21:59:00.002590 2017] [ssl:warn] [pid 1224] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Mar 08 21:59:00.002685 2017] [ssl:warn] [pid 1224] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Mar 08 21:59:00.002941 2017] [lbmethod_heartbeat:notice] [pid 1224] AH02282: No slotmem from mod_heartmonitor
[Wed Mar 08 21:59:00.090436 2017] [mpm_prefork:notice] [pid 1224] AH00163: Apache/2.4.25 (Unix) OpenSSL/1.0.2j PHP/5.6.30 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Wed Mar 08 21:59:00.090604 2017] [core:notice] [pid 1224] AH00094: Command line: '/opt/lampp/bin/httpd -E /opt/lampp/logs/error_log -D SSL -D PHP'

I am not enough into php or MySql to solve the problem on my own, im afraid. So if anybody can come up with some ideas I would be very happy!

So long

pete13
Neuling
Beiträge: 19
Registriert: Fr 16. Sep 2016, 14:40

Re: Probleme bei Installation - fehlen von /install

Do 9. Mär 2017, 12:28

Hi,
this log file contains (in my opinion) nothing really related to the "(..) Page not found" error. Correct my if I'm wrong.
Is there any entry in the symfony log files?
/$runalyepath/var/log/prod.log
/$runalyzepath/var/log/symfony.log

Besides you should ensure that the defined server name in the webserver config matches the name in your SSL certificate.

rnr
Neuling
Beiträge: 2
Registriert: Mi 8. Mär 2017, 13:21

Re: Probleme bei Installation - fehlen von /install

Do 9. Mär 2017, 12:49

laufhannes hat geschrieben:
Mi 8. Mär 2017, 16:27
rnr hat geschrieben:
Mi 8. Mär 2017, 16:03
"Sorry, page not found" .I'm not a programer and not very familiar with symfony framework but think that problem is with some URL routing configuration settings.

Yep. Every 'Sorry, page not found' indicates a misconfiguration of the webserver. We suggest to mount a (sub)domain directly to the web-directory. In that case, nobody can (easily) access configuration files and Symfony does not have problems with url detection. In addition, we assume that everyone who wants to install a local version of RUNALYZE knows about 'url rewriting' and how to achieve that with his server.

As pete13 mentions, in case of any problems, there's in general a log entry in the server logs or in symfony logs var/logs/* (as long as the http request reaches symfony/runalyze) that gives a hint for the exact problem.


Hi laufhannes,
thanks for your promt responce.
I will try to install on sub domain and If I have same issue will post here.
Bild

yege
Neuling
Beiträge: 2
Registriert: So 23. Apr 2017, 11:41

Re: Probleme bei Installation - fehlen von /install

So 23. Apr 2017, 12:38

Leider kriege auch ich hier runalyzer ab Version 3.x.x nicht mehr installiert (auch 4.x nicht). Die Anleitung zur Installation mit /localhost/runalyze/install.php scheint ja veraltet zu sein. Bei http://localhost/runalyze/install kriege ich nur einen 404 Fehler. Auch localhost/runalyze/web/app.php/ ergibt bei mir nur eine Meldung 500.
Meine lokale Installation
Linux Mint 18.0
Apache 2.4.18
PHP 7.0.15
mySql 5.7.17

Was habe ich bis jetzt probiert?
Die Datenbank ist angelegt (nach Vorgabe von timekiller: Name runalyze, ohne Passwort, root als Benutzer). Die Datei default_config.yml wurde nach /runalyze/data/ verschoben und umbenannt. Die Version runalyze 2.6.9 hatte ich mal testweise installiert und ich bekam auch den Konfigurationsbildschirm zu sehen, der mir anzeigte das alles OK sei. Habe die Installation dann aber nicht weitergeführt weil ich gerne die aktuelle Version hätte. Ich kriege mit /localhost/runalyze im Browser zwar alle Files angezeigt und kann auch die einzelnen Ordner/Files öffnen, nur installiert kriege ich nichts.
Könnte mir jemand sagen was ich falsch mache :( ? Irgendwie scheine ich aber nicht der Einzige zu sein der jetzt Probleme hat bei über 500 Zugriffen auf das Thema. Könnte man nicht in einer späteren Version wieder auf die alte Installationsvariante zurück gehen?

Benutzeravatar
mipapo
Administrator
Beiträge: 878
Registriert: Mo 29. Jul 2013, 20:26
Wohnort: Kiel
Kontaktdaten: Website Facebook Twitter

Re: Probleme bei Installation - fehlen von /install

So 23. Apr 2017, 13:53

Die richtige Anleitung lesen hilft! https://docs.runalyze.com/en/latest/ins ... n/4.x.html
Weiterhin nicht vergessen: Self-Hosted Installationen sind auf sich alleine gestellt und bekommen keinen garantieren Support von uns bei Problemen. Dafür haben wir keine Zeit.
könnte man nicht in einer späteren Version wieder auf die alte Installationsvariante zurück gehen?
Nein
###Donate to RUNALYZE###
Erste Schritte - Höhenmeter (Korrektur & Berechnung) - Nutzerhilfe/User help - Admin docs-

Run Happy!,
Michael
P.S. Ich antworte gerne kurz und knackig ;)
Bild

yege
Neuling
Beiträge: 2
Registriert: So 23. Apr 2017, 11:41

Re: Probleme bei Installation - fehlen von /install

So 23. Apr 2017, 22:41

Alles klar.

Zurück zu „Runalyze v3.2.x“

Advertisement

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast