Forum rules
RUNALYZE started as one-man-project with only one user and has grown to an app with around 13.000 users of our official online version. Server requirements and complexity of the app and its configuration grow with the feature list. Please understand that our main focus is on implementing new features and serving a performant online version. Therefore, support for local installations is limited and we cannot guarantee any support.

Please always provide log files (and screenshots, activity files if it makes sense) and all other needed information: https://docs.runalyze.com/en/latest/support.html

We spend our leisure time to make RUNALYZE as good as possible and we still have tons of great ideas, but time is scarce and after a hard training we first need some fruits or a smoothie. You can support the development of RUNALYZE with every financial contribution — We highly appreciate every grant.
https://blog.runalyze.com/donate/
pete13
Neuling
Posts: 19
Joined: Fri 16. Sep 2016, 14:40

Re: Previous migrations

Fri 3. Mar 2017, 11:18

Ja okay, kein Dump von heute oder letzte Woche sondern von vor einem Monat oder so.
Da wurde die "falsche" Migration ja noch nicht durchgeführt und ich müsste dann nur das Training von einem Monat nachtragen. Ist im Januar bei mir nicht soviel. :D
0 x

User avatar
laufhannes
Core developer
Posts: 737
Joined: Mon 29. Jul 2013, 20:59

Re: Previous migrations

Fri 3. Mar 2017, 11:45

pete13 wrote:
Fri 3. Mar 2017, 10:38
Das ist klar. Habe ich geprüft.
Spalte "gender" ist vorhanden.
Cache gelöscht, Seite neu geladen. Fehlermeldung im log ist weg.
Anmeldeversuch schlägt dennoch fehl mit der mehrfach genannten Meldung.
Ich komme nicht ganz mit, welche Logmeldung jetzt beim Anmeldeversuch erscheint. Die fehlende Spalte `t0.gender` oder der Twig_Runtime_Error? Die Spalte hattest du ja in der Datenbank kontrolliert. Wenn der Fehler auch nach Leeren des Caches weiterhin auftaucht, obwohl sie in der Datenbank vorhanden ist, scheint ja eine andere Datenbank verwendet zu werden. Solange es sich nicht um ein Cache-Problem handelt, denkt sich der Code zumindest nicht einfach die Spalte weg.

Wenn die Spalte nicht in der Datenbank ist, kann das Verwenden eines früheren Dumps + erneute Migration helfen. Wenn es sich aber um den Twig_Runtime_Error handelt, hat das Ganze nichts mit der Datenbank (und damit der Migration) zu tun.

Wenn es nur die Meldung "Die Authentifikation konnte wegen eines Systemproblems nicht bearbeitet werden." ohne Eintrag im Log ist (was ich gerade vermute, beim erneuten Lesen wird das dann doch etwas klarer ;) ), kann es mit dem Dump zusammenhängen. Hast du bereits den Debugmodus (Zugriff über app_dev.php bzw. in der web/app.php den Mode auf 'dev' setzen) probiert? Vllt. ist Symfony dann ja auskunftfreudiger.
0 x
User help -- short questions via Twitter, Facebook

pete13
Neuling
Posts: 19
Joined: Fri 16. Sep 2016, 14:40

Re: Previous migrations

Fri 3. Mar 2017, 13:41

Ja, das ist alles ein bisschen durcheinander geraten hier.
Verzeihung dafür. :oops:

Also der Twig Runtime Error ist aufgetreten aber behoben durch den Hinweis auf eine Konfiguration im open_base_dir in PHP.
Der `t0.gender Error trat dann auch, ist aber nach dem löschen des Caches nicht mehr aufgetreten.
Die Spalte ist vorhanden und beim Anmelden kommt besagte Fehlermeldung
"Die Authentifikation konnte wegen eines Systemproblems nicht bearbeitet werden."

Ich werde als nächstes den Debugmodus mal anstellen (kannte ich vorher nicht) und schauen ob da was bei raus kommt.
Ansonsten werde ich den Weg gehen, ein frisches 3.2 aufzusetzen und einen Dump von vor der Migration einzuspielen und dann nur den letzten Monat nach zu tragen.
Das sollte dann klappen.
0 x

Return to “Runalyze v3.1.x”

Who is online

Users browsing this forum: No registered users and 1 guest