Forum rules
RUNALYZE started as one-man-project with only one user and has grown to an app with around 13.000 users of our official online version. Server requirements and complexity of the app and its configuration grow with the feature list. Please understand that our main focus is on implementing new features and serving a performant online version. Therefore, support for local installations is limited and we cannot guarantee any support.

Please always provide log files (and screenshots, activity files if it makes sense) and all other needed information: https://docs.runalyze.com/en/latest/support.html

We spend our leisure time to make RUNALYZE as good as possible and we still have tons of great ideas, but time is scarce and after a hard training we first need some fruits or a smoothie. You can support the development of RUNALYZE with every financial contribution — We highly appreciate every grant.
https://blog.runalyze.com/donate/
hps
Neuling
Posts: 3
Joined: Fri 6. Jan 2017, 13:57

[Fixed] Upgrade from 3.0 to 3.1: doctrine_migrations.organize_migrations must be defined

Tue 10. Jan 2017, 11:21

Hallo,

ich betreibe Runalyze local unter XAMPP.
Wenn ich /WEB/UPDATE starte, bekomme ich folgende Meldung in einem schwarzen Fenster angezeigt:

[Symfony\Component\DependencyInjection\Exception\InvalidArgumentException]
The parameter "doctrine_migrations.organize_migrations" must be defined.


doctrine:migrations:status [--show-versions] [--configuration [CONFIGURATION]] [--db-configuration [DB-CONFIGURATION]] [--db DB] [--em EM] [--shard SHARD] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--]

Das Update führt dann zu einem Fehler.

Gruß
Hans-Peter
0 x

User avatar
mipapo
Administrator
Posts: 1354
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Upgrade from 3.0 to 3.1

Tue 10. Jan 2017, 11:26

Bitte erstellt für neue Probleme ein neues Thema. Danke
0 x
###Donate to RUNALYZE###
Höhenmeter (Korrektur & Berechnung) - Nutzerhilfe/User help -

Run Happy!,
Michael
P.S. Ich antworte gerne kurz und knackig ;)
Image

User avatar
laufhannes
Core developer
Posts: 753
Joined: Mon 29. Jul 2013, 20:59

Re: Upgrade from 3.0 to 3.1: doctrine_migrations.organize_migrations must be defined

Tue 10. Jan 2017, 11:40

Du hast das Update vermutlich von https://dl.runalyze.com/ geladen und nicht direkt über Git, oder? Wenn du nach "doctrine/doctrine-migrations-bundle" in der composer.lock im Hauptverzeichnis suchst, steht dort "v1.2.0" als Version?

Du könntest einmal probieren in deiner data/config.yml folgendes hinzuzufügen (ohne Leerzeichen davor, also auf einer Höhe mit "parameters:", im Gegensatz zu all den anderen Variablen):

Code: Select all

doctrine_migrations.organize_migrations: false
0 x
User help -- short questions via Twitter, Facebook

hps
Neuling
Posts: 3
Joined: Fri 6. Jan 2017, 13:57

Re: Upgrade from 3.0 to 3.1: doctrine_migrations.organize_migrations must be defined

Tue 10. Jan 2017, 14:12

Ich habe jetzt nochmal die Version von Git genommen.
In der Composer.lock steht an der beschriebenen Stelle "v1.2.0" als Version.
Das Problem bleibt das gleiche.
Der Eintrag in der config.yml bringt auch nichts.
0 x

User avatar
mipapo
Administrator
Posts: 1354
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Upgrade from 3.0 to 3.1: doctrine_migrations.organize_migrations must be defined

Tue 10. Jan 2017, 15:08

Den Master in Git sollst du auch nicht nehmen. Wenn du die Version 3.1 haben möchtest musst du auf den Branch support/3.1.x wechseln.
Am Besten ist es aber, wenn du die Pakete unter https://github.com/Runalyze/Runalyze/releases (runalyze-....) nimmst.

Hast du nach dem Ändern der config.yml in var/cache den "prod" Ordner einmal gelöscht? Sonst wird die Konfiguration nicht übernommen
0 x
###Donate to RUNALYZE###
Höhenmeter (Korrektur & Berechnung) - Nutzerhilfe/User help -

Run Happy!,
Michael
P.S. Ich antworte gerne kurz und knackig ;)
Image

hps
Neuling
Posts: 3
Joined: Fri 6. Jan 2017, 13:57

Re: Upgrade from 3.0 to 3.1: doctrine_migrations.organize_migrations must be defined

Tue 10. Jan 2017, 15:36

Ich habe jetzt nochmal alles komplett gelöscht, das data Verzeichnis und auch die Datenbank vom Backup nochmal neu eingespielt.
Danach hat es dann funktioniert.

Vielen Dank für die Unterstützung
0 x

Return to “Runalyze v3.1.x”

Who is online

Users browsing this forum: No registered users and 1 guest