Forum rules
RUNALYZE started as one-man-project with only one user and has grown to an app with around 13.000 users of our official online version. Server requirements and complexity of the app and its configuration grow with the feature list. Please understand that our main focus is on implementing new features and serving a performant online version. Therefore, support for local installations is limited and we cannot guarantee any support.

Please always provide log files (and screenshots, activity files if it makes sense) and all other needed information: https://docs.runalyze.com/en/latest/support.html

We spend our leisure time to make RUNALYZE as good as possible and we still have tons of great ideas, but time is scarce and after a hard training we first need some fruits or a smoothie. You can support the development of RUNALYZE with every financial contribution — We highly appreciate every grant.
https://blog.runalyze.com/donate/
chortyenz
Neuling
Posts: 3
Joined: Wed 4. Jan 2017, 11:44

[Fixed] Raspbian Jessie Installationsproblem

Wed 4. Jan 2017, 12:12

Hallo zusammen.
Ich stehe vor einem Problem wo ich grad irgendwie nicht weiter komme. Auch Google konnte mich nicht wirklich weiter helfen bzw. ich habe es teils nicht verstanden.

Ich möchte gerne Runalyze auf einen BananaPi (Raspberry) installieren.
Als Distro verwende ich die Raspbian Jessie.
Das ganze soll mit Nginx, PHP7 und MariaDB installiert werden.
Folgende Versionen sind installiert:
nginx 1.10.2
PHP 7.0.14-2

Ich habe dann die Runalyze 3.1 Version entsprechend in den/var/www/Runalyze Ordner entpackt.
So nun weiß ich nicht ob ich es ab hier richtig gemacht habe.

Ich habe dann mit apt-get install npm (4.0.5) und apt-get install composer (1.2.2) die zwei benötigten Pakete noch installiert.
Dann habe ich entsprechen im Ordner /var/www/Runalyze den Befehl composer install ausgeführt.
Soweit alles ok.
Dann habe ich npm install ausgeführt.
Hier bekommen ich dann folgende Fehlermeldung

Code: Select all

npm ERR! git clone git@github.com:github:gulpjs/gulp Cloning into bare repository '/root/.npm/_git-remotes/git-github-com-github-gulpjs-gulp-e2adb3d8'...
npm ERR! git clone git@github.com:github:gulpjs/gulp Permission denied (publickey).
npm ERR! git clone git@github.com:github:gulpjs/gulp fatal: Could not read from remote repository.
npm ERR! git clone git@github.com:github:gulpjs/gulp
npm ERR! git clone git@github.com:github:gulpjs/gulp Please make sure you have the correct access rights
npm ERR! git clone git@github.com:github:gulpjs/gulp and the repository exists.
npm ERR! notarget No compatible version found: gulp@'github:gulpjs/gulp#4.0'
npm ERR! notarget Valid install targets:
npm ERR! notarget ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.7","0.0.8","0.0.9","0.1.0","0.2.0","1.0.0","1.1.0","1.2.0","1.2.1","2.0.0","2.0.1","2.1.0","2.2.0","2.3.0","2.4.0","2.4.1","2.6.0","2.6.1","2.7.0","3.0.0","3.1.1","3.1.2","3.1.3","3.1.4","3.2.0","3.2.1","3.2.2","3.2.3","3.2.4","3.2.5","3.3.0","3.3.1","3.3.2","3.3.4","3.4.0","3.5.0","3.5.1","3.5.2","3.5.5","3.5.6","3.6.0","3.6.1","3.6.2","3.7.0","3.8.0","3.8.1","3.8.2","3.8.3","3.8.4","3.8.5","3.8.6","3.8.7","3.8.8","3.8.9","3.8.10","3.8.11","3.9.0","3.9.1"]
npm ERR! notarget
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

npm ERR! System Linux 3.4.112-sun7i
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! cwd /var/www/html/Runalyze-master
npm ERR! node -v v0.10.29
npm ERR! npm -v 1.4.21
npm ERR! code ETARGET
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /var/www/html/Runalyze-master/npm-debug.log
npm ERR! not ok code 0
Was kann ich eurer Meinung nach noch tun? Ich bin der Meinung das etwas mit der gulp Version nicht passt bzw. etwas nicht installiert werden konnte.
Wenn Ich mehr Infos angeben muss Bitte angeben.
Ich bin kein Profi was Webanwendungen angeht. Ich habe mir das alles bei Google angeeignet. Ich habe auch noch mit nodejs gearbeitet.
0 x

User avatar
mipapo
Administrator
Posts: 1220
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Raspbian Jessie Installationsproblem

Wed 4. Jan 2017, 12:17

Lade dir einfach die fertigen Pakete (runalyze-...) runter, dann musst du dich nicht mit npm und co rumplagen.
https://github.com/Runalyze/Runalyze/releases
0 x

chortyenz
Neuling
Posts: 3
Joined: Wed 4. Jan 2017, 11:44

Re: Raspbian Jessie Installationsproblem

Wed 4. Jan 2017, 13:55

Hallo mipapo.
Danke für Deine Antwort. Dann habe ich das mit der Installation komplett falsch verstanden.
Also nochmal von vorne. Ich habe nun die zip Datei entsprechend aus Deinem Link heruntergeladen.
Die habe ich dann entsprechend entpackt und dem User www-data zugewiesen.
Dann entsprechend die config.yml kopiert und entsprechend angepasst.
Hier mal einer kurze Übersicht zu meinem runalyzer Verzeichnis:

Code: Select all

total 216
drwxr-xr-x  5 www-data www-data   4096 Dec  5 20:07 app
drwxr-xr-x  2 www-data www-data   4096 Dec  5 20:07 bin
-rw-r--r--  1 www-data www-data    285 Dec  5 20:07 bower.json
drwxr-xr-x  3 www-data www-data   4096 Dec  5 20:07 call
-rw-r--r--  1 www-data www-data   3366 Dec  5 20:07 CHANGELOG.md
-rw-r--r--  1 www-data www-data   1295 Dec  5 20:07 composer.json
-rw-r--r--  1 www-data www-data 135933 Dec  5 20:07 composer.lock
-rw-r--r--  1 www-data www-data   2239 Dec  5 20:07 dashboard.php
drwxr-xr-x  9 www-data www-data   4096 Jan  4 13:40 data
-rw-r--r--  1 www-data www-data   2987 Dec  5 20:07 gulpfile.js
drwxr-xr-x 13 www-data www-data   4096 Dec  5 20:07 inc
drwxr-xr-x  5 www-data www-data   4096 Dec  5 20:07 lib
-rw-r--r--  1 www-data www-data    708 Dec  5 20:07 package.json
drwxr-xr-x 19 www-data www-data   4096 Dec  5 20:07 plugin
-rw-r--r--  1 www-data www-data   5168 Dec  5 20:07 README.md
-rw-r--r--  1 www-data www-data   2426 Dec  5 20:07 resources.json
drwxr-xr-x  3 www-data www-data   4096 Dec  5 20:07 src
drwxr-xr-x  4 www-data www-data   4096 Dec  5 20:07 var
drwxr-xr-x 28 www-data www-data   4096 Jan  4 13:43 vendor
drwxr-xr-x  5 www-data www-data   4096 Dec  5 20:07 web
Wenn ich dann IP/runalyzer/install oder IP/runalyzer/web/install eingebe bekomme ich ein 404 Not found im Browser angezeigt.
Was mache ich hier noch falsch?
Also das mit dem install Befehl verstehe ich nicht in der Anleitung.

Danke für Deine Hilfe.
0 x

User avatar
mipapo
Administrator
Posts: 1220
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Raspbian Jessie Installationsproblem

Wed 4. Jan 2017, 14:00

Ist deine nginx-Konfiguration denn richtig?
https://docs.runalyze.com/en/latest/ins ... e-on-nginx

Starte am besten einer (Sub)domain. Damit umgehst du viele Probleme.
0 x

chortyenz
Neuling
Posts: 3
Joined: Wed 4. Jan 2017, 11:44

Re: Raspbian Jessie Installationsproblem

Thu 5. Jan 2017, 21:17

Hallo mipapo.
Danke für den Tipp mit der Nginx Config.
Ich habe mir das nochmal etwas genauer angesehen und den Fehler gefunden.
Muss mich mal mehr mit dem Nginx auseinander setzen.....
Die Webanwendung ist echt fix auf dem BananaPi.

Danke für die schnelle Hilfe hier.
Nun muss ich mich mal ein wenig mit runalyze auseinander setzen.

Also Danke nochmal!!!!
0 x

User avatar
mipapo
Administrator
Posts: 1220
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Raspbian Jessie Installationsproblem

Sun 8. Jan 2017, 20:20

Top! Freut mich zu hören, dass das geklappt hat :)
0 x

Return to “Runalyze v3.1.x”

Who is online

Users browsing this forum: No registered users and 1 guest