kiaro
Neuling
Posts: 12
Joined: Sun 13. Dec 2015, 17:59

Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 07:53

Runalyze läuft lokal auf einem Raspberry PI (Debian). Diesen habe ich neu aufgesetzt und die komplette runalyze DB per SQL wieder importiert. Die Version von runalyze war jeweils 2.6.1. Die alten Daten sind auch alle da, jedoch bestehen zwei Probleme.

1. Die Sprache ist auf deutsch eingestellt. In der DB steht in der users Tabelle auch "de". Es wird aber englisch angezeigt. Auch wenn ich auf der Login Seite die Sprache umstelle ist alles englisch.

2. Die Wetterdaten werden nicht geladen. Am API Key hat sich nichts geändert. Gebe ich die URL im Browser ein kommen die Daten auch. Runalyze bringt aber diesen Fehler:

Code: Select all

file_get_contents(http://api.openweathermap.org/data/2.5/weather?q=Karlsruhe, de&APPID=foo): failed to open stream: HTTP request failed! HTTP/1.1 400 Bad Request (in /var/www/html/runalyze/inc/system/class.Filesystem.php::61)
Gruß,
Michael
0 x

User avatar
mipapo
Administrator
Posts: 1219
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 08:12

Zu 1.
Du musst die Sprachen auf deinen Linuxsystem einmal erzeugen:
http://docs.runalyze.com/en/latest/inst ... tributions
Bspw.:

Code: Select all

locale-gen de_DE.UTF-8
Zu 2.
Mich wundert woher "APPID=foo" kommt. Sieht ja eher nach einem falschen API Key aus. "FOO" ist jedenfalls kein gültiger Open Weather API KEY
Woher kommt die Meldung?
php5-curl ist installiert?

Zu den Wetterdaten beachte auch bitte die Änderungen in der Version 2.6: viewtopic.php?f=36&t=449
0 x

kiaro
Neuling
Posts: 12
Joined: Sun 13. Dec 2015, 17:59

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 08:25

1. Die locale habe ich erzeugt. Hat aber keinen Unterschied gebracht. Auch nach Ausloggen/Einloggen ists auf englisch.

2. Statt "foo" habe ich natürlich meinen Key eingetragen. Nur möchte ich nicht dass der hier öffentlich sichtbar ist. ;) Curl ist installiert. Aber das Paket php5-curl war nicht installiert. Werde das nochmal probieren.
0 x

User avatar
mipapo
Administrator
Posts: 1219
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 08:30

kiaro wrote:1. Die locale habe ich erzeugt. Hat aber keinen Unterschied gebracht. Auch nach Ausloggen/Einloggen ists auf englisch.
Apache neustarten?
Fehlt das php5-gettext Paket?
0 x

kiaro
Neuling
Posts: 12
Joined: Sun 13. Dec 2015, 17:59

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 08:31

zu 2: Ist erledigt. Das fehlende "php5-curl" war das Problem.

Deshalb stand früher wohl auf der admin.php auch "Perl kann nicht genutzt werden". Das hat mich verwirrt, denn perl war ja korrekt installiert. Aber jetzt ist auf der admin.php alles grün. :)
0 x

kiaro
Neuling
Posts: 12
Joined: Sun 13. Dec 2015, 17:59

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 08:33

NGINX hatte ich neu gestartet. php-gettext und gettext ist installiert.
0 x

User avatar
mipapo
Administrator
Posts: 1219
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 08:40

/etc/init.d/php5-fpm restart?

Siehe auch stackoverflow. Google sollte dir eigentlich bei dem Problem behilflich sein. Es ist kein RUNALYZE bezogenes Problem.
0 x

kiaro
Neuling
Posts: 12
Joined: Sun 13. Dec 2015, 17:59

Re: Probleme Locale & Wetter nach Neuinstallation

Wed 6. Jul 2016, 19:02

Das wars. Danke für den Support. :)

PS: Ist das erste Mal dass ich NGINX verwende. Hat man wohl gemerkt... ;)
0 x

Return to “Runalyze v2.6.x”

Who is online

Users browsing this forum: Google [Bot] and 1 guest