beroxx0815
Neuling
Posts: 2
Joined: Sat 12. Mar 2016, 17:02
Location: Karlsruhe

Neuer Account - Keine Reg-Mail

Sat 12. Mar 2016, 17:30

Ich habe mir Runalyze bei meinem Hoster (1und1) installiert - alles wunderbar. Nur der Mailversand nach Accountregistrierung funktioniert nicht.

("Das Versenden des Links ist fehlgeschlagen. Bitte kontaktiere den Administrator.")

Wie ist denn der korrekte Syntax der SMTP-Felder? Ich habe
SMTP: Host = smtp.1und1.de
SMTP: Port = 587
SMTP: Verschlüsselung = <leer> Was muss hier hin? Ich muss TLS benutzen...

Im login.php.log... steht folgendes:

WARNING stream_socket_client(): unable to connect to smtp.1und1.de:587 (Die Wartezeit für die Verbindung ist abgelaufen) (in /homepages/26/d72102115/htdocs/runalyze/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php::263)
ERROR » Mail could not be sent: Connection could not be established with host smtp.1und1.de [Die Wartezeit für die Verbindung ist abgelaufen #110]

/homepages/26/d72102115/htdocs/runalyze/inc/system/class.AccountHandler.php::457
System::sendMail(Test1@domain.de, Aktiviere deinen RUNALYZE Account, Danke für die Registrierung, Test!

Du kannst deinen Account (Benutzername = Test1) über den folgenden Link aktivieren:
http://www.domain.de/login.php?activate ... e7f86b891a)

/homepages/26/d72102115/htdocs/runalyze/inc/system/class.AccountHandler.php::240
AccountHandler::setAndSendActivationKeyFor(12, )

/homepages/26/d72102115/htdocs/runalyze/inc/system/class.AccountHandler.php::210
AccountHandler::createNewUserFromPost()

/homepages/26/d72102115/htdocs/runalyze/inc/tpl/tpl.loginWindow.php::63
AccountHandler::tryToRegisterNewUser()

/homepages/26/d72102115/htdocs/runalyze/login.php::39
include(/homepages/26/d72102115/htdocs/runalyze/inc/tpl/tpl.loginWindow.php)
Stefan (stka) hatte letztes Jahr schon mal so ein Problem (Nach Installation), allerdings auch keine Lösung...

Nachdem ich jetzt alle mir möglich erscheinenden Varianten ausprobiert habe weiss ich nicht mehr weiter...

Apropos: Wie bekomme ich eigentlich die ganzen fehlgeschlagenen Test-User wieder aus der Datenbank gelöscht?

Ich hoffe es erbarmt sich jemand ;-)

Gruß,
Ben
0 x

User avatar
mipapo
Administrator
Posts: 1268
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Neuer Account - Keine Reg-Mail

Sat 12. Mar 2016, 17:51

Du könntest den Hashwert aus dem Feld activation_hash entfernen. Dann ist der Nutzer aktiviert.

zur Verschlüsselung: Schreib "TLS" hin ;)
0 x

beroxx0815
Neuling
Posts: 2
Joined: Sat 12. Mar 2016, 17:02
Location: Karlsruhe

Re: Neuer Account - Keine Reg-Mail

Sat 12. Mar 2016, 18:10

Danke für dein schnelles Feedback.
mipapo wrote:Du könntest den Hashwert aus dem Feld activation_hash entfernen. Dann ist der Nutzer aktiviert.
Ich nehme an du redest von einer direkten Anpassung in der mySQL-Datenbank.... Gibt's auch eine Lösung, wenn ich des SQL nicht mächtig bin?
Oder vielleicht ein Muster SQL-Kommando?
mipapo wrote:zur Verschlüsselung: Schreib "TLS" hin ;)
...dann sieht der Log-Eintrag so aus....:
stream_socket_client(): unable to connect to TLS://smtp.1und1.de:587 (Unable to find the socket transport "TLS" - did you forget to enable it when you configured PHP?) (in /homepages/26/d72102115/htdocs/runalyze/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php::263)
ERROR » Mail could not be sent: Connection could not be established with host smtp.1und1.de [Unable to find the socket transport "TLS" - did you forget to enable it when you configured PHP? #1464650008]
Bringt also leider auch nix... :-(

+ben
0 x

User avatar
mipapo
Administrator
Posts: 1268
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Neuer Account - Keine Reg-Mail

Sat 12. Mar 2016, 18:18

Code: Select all

UPDATE runalyze_account SET activation_hash=''
aktiviert alle nicht aktivierten Nutzer. Irgendwie ausführen musst du die Query schon selbst.


Zu dem Fehler finde ich nur:
http://stackoverflow.com/questions/3275 ... t-when-you
Kann also sein, das bei deinem Hoster das nicht aktiviert ist.

Funktioniert vielleicht die Kleinschreibung? tls
0 x

Return to “Runalyze v2.4.x”

Who is online

Users browsing this forum: No registered users and 1 guest