niederrheiner
Runalyzer
Posts: 27
Joined: Mon 19. Aug 2013, 18:42

[Gelöst] Installation von v2.1

Sun 19. Jul 2015, 17:11

Hallo an Alle,
bei der Installation von runalyze-master tritt folgede Fehlermeldung in /var/log/http/error_log auf:

Code: Select all

[Sun Jul 19 16:56:40.440790 2015] [:error] [pid 376] [client 192.168.178.148:54224] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /srv/http/Runalyze-master/inc/tpl/tpl.installerFooter.php on line 4, referer: http://webpi/Runalyze-master/install.php
in meiner /etc/localtime steht folgendes:

Code: Select all

lrwxrwxrwx 1 root root 33 May 31 11:13 /etc/localtime -> /usr/share/zoneinfo/Europe/Berlin
?
Meine Frage: was bedeutet die Fehlermeldung und wie kann ich den Fehler beheben?

Mein System:
4.0.8-2-ARCH
php 5.6.11-1
mariadb 10.0.20-1
apache 2.4.16-1
runalyze-v2.0.4

Danke für Eure Hilfe und Tipps.

Bis dann ...
MfG
Günter
0 x

niederrheiner
Runalyzer
Posts: 27
Joined: Mon 19. Aug 2013, 18:42

Re: Installation von v2.1

Sun 19. Jul 2015, 18:07

den Fehler habe ich behoben, durch den entsprechenden Eintrag in der /etc/php/php.ini.
Es bleibt aber immernoch das nicht automatische Schreiben der config.php

Bis dann ...
MfG
Günter
0 x

User avatar
laufhannes
Core developer
Posts: 729
Joined: Mon 29. Jul 2013, 20:59

Re: Installation von v2.1

Sun 19. Jul 2015, 19:40

Der "Fehler" ist ja nur eine PHP-Warnung, sollte dementsprechend auch keine negativen Auswirkungen haben.

Was die config.php betrifft: Die kann natürlich nur geschrieben werden, wenn der entsprechende Prozess dort Schreibrechte besitzt. Ich sehe kein Problem darin, dass Nutzer die Datei per Hand anlegen müssen, wenn die Schreibrechte eben nicht vorhanden sind?
0 x
User help -- short questions via Twitter, Facebook

User avatar
mipapo
Administrator
Posts: 1219
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Installation von v2.1

Sun 19. Jul 2015, 21:05

Wir können uns ja auch nur schlecht Rechte irgendwie erschleichen :D
0 x

niederrheiner
Runalyzer
Posts: 27
Joined: Mon 19. Aug 2013, 18:42

Re: Installation von v2.1

Mon 20. Jul 2015, 08:11

so, das Problem mit den Schreibrechten habe ich beseitigt. Die Installation läuft nun bis zur Datenbankerstellung durch und es werden auch die entsprechenden Tabellen erstellt. Danach erscheint aber, der im Anhang gezeigte Bildschirm.
Mir ist dann noch folgende Fehlermeldung i /var/log/http/error_log aufgefallen:

Code: Select all

[Mon Jul 20 07:51:42.724111 2015] [:error] [pid 6985] [client 192.168.178.148:56103] PHP Warning:  require_once(/srv/http/Runalyze-master/inc/../vendor/autoload.php): failed to open stream: Datei oder Verzeichnis nicht gefunden in /srv/http/Runalyze-master/inc/system/class.Autoloader.php on line 22
[Mon Jul 20 07:51:42.724578 2015] [:error] [pid 6985] [client 192.168.178.148:56103] PHP Fatal error:  require_once(): Failed opening required '/srv/http/Runalyze-master/inc/../vendor/autoload.php' (include_path='.:/usr/share/pear') in /srv/http/Runalyze-master/inc/system/class.Autoloader.php on line 22
[Mon Jul 20 08:01:26.782200 2015] [:error] [pid 3438] [client 192.168.178.148:56172] PHP Warning:  require_once(/srv/http/Runalyze-master/inc/../vendor/autoload.php): failed to open stream: Datei oder Verzeichnis nicht gefunden in /srv/http/Runalyze-master/inc/system/class.Autoloader.php on line 22, referer: http://webpi/Runalyze-master/install.php
[Mon Jul 20 08:01:26.782724 2015] [:error] [pid 3438] [client 192.168.178.148:56172] PHP Fatal error:  require_once(): Failed opening required '/srv/http/Runalyze-master/inc/../vendor/autoload.php' (include_path='.:/usr/share/pear') in /srv/http/Runalyze-master/inc/system/class.Autoloader.php on line 22, referer: http://webpi/Runalyze-master/install.php
Die erste Fehlermeldung trat nach dem oder vor dem ? Schreiben der config.php auf und die zweite vor 0der nach ? dem Erstellen der Datenbank auf. Im ganzen Runalayze-master Verzeichnis existiert keine Datei autoload.php. Ich nehme an, das der Fehler nicht an der Entwicklerversion liegt.

Wo kann ich ansetzen und welche Informationen braucht Ihr um mich auf die richtige Spur zu setzen?

Danke für Eure Hilfe und Tipps.

Bis dann ...
MfG
Günter
Attachments
runalyze-master.png
runalyze-master.png (1.1 MiB) Viewed 3317 times
0 x

User avatar
mipapo
Administrator
Posts: 1219
Joined: Mon 29. Jul 2013, 20:26
Location: Kiel
Contact: Website Facebook Twitter

Re: Installation von v2.1

Mon 20. Jul 2015, 09:21

@Günter- Zu dem Autoload. Mit Version 2.1 wird composer benötigt. (https://getcomposer.org/)
Nutze doch am Besten unseren offiziellen Release. Da haben wir dir die ganze Arbeit schon abgenommen
0 x

niederrheiner
Runalyzer
Posts: 27
Joined: Mon 19. Aug 2013, 18:42

Re: Installation von v2.1

Mon 20. Jul 2015, 18:16

hört sich gut an.Wann uuuuuuuuuuuuuuuuungefähr kann man denn mit der neuen Version rechnen?

In freudiger Erwartung der neuen Version

bis dann ...
Mfg
Günter
0 x

User avatar
laufhannes
Core developer
Posts: 729
Joined: Mon 29. Jul 2013, 20:59

Re: Installation von v2.1

Mon 20. Jul 2015, 20:55

0 x
User help -- short questions via Twitter, Facebook

Return to “Runalyze v2.1.x”

Who is online

Users browsing this forum: No registered users and 1 guest